آموزشوردپرس

آموزش بروز کردن jQuery در وردپرس

آیا شما از آخرین نسخه jQuery استفاده می کنید؟ اینکه شما از چه نسخه ای استفاده می کنید بسیار مهم است! چرا که وردپرس، قالب ها و افزونه های وردپرس به شدت به جی کوئری وابسته هستند. در این پست به شما آموزش می دهم که چطور براحتی با چند کلیک جی کوئری را در سایت خود بروز کنید.

اول از هر کاری باید بتونیم نسخه جی کوئری سایت خودمان را مشخص کنیم؟ برای این کار کافیست در حالت inspect گوگل کروم، در کنسول عبارت زیر را وارد کنید و بعد از آن کروم نسخه جی کوئری سایت شما را مشخص می کند:

jQuery.fn.jquery

برای بروز رسانی به آخرین نسخه پایدار جی کوئری در وردپرس می توانید افزونه jQuery Updater را نصب و فعال کنید. این افزونه همیشه نسخه جی کوئری سایت شما را در آخرین نسخه پایدار نگه می دارد. تنها مشکل این افزونه این است که با برخی از افزونه های فارسی مشکل دارد و اگر آنها در سایت شما در حال اجرا باشند این افزونه درست کار نمی کند.

در این حالت می توانید از افزونه Version Control for jQuery استفاده کنید. این افزونه کاری مشابه قبل را انجام می دهد ولی می توانید در تنظیمات آن مشخص کنید که نسخه اولیه شما چی باشد؟! آیا می خواهید به نسخه جدید مهاجرت کنید یا خیر ؟ همچنین با افزونه های فارسی که حداقل من داشتم، مشکلی نداشت.

نوشته های مشابه

دکمه بازگشت به بالا

حتما ما را در توییتر دنبال کنید